Friday, May 15, 2015

Upgrading the Web Froms Application to 4.5 and make it Web API Friendly


Objective:
To integrate WEB API 2.0 and ANGULAR.JS for current Web Form Application

I was able to successfully integrate WEB API 1.0 with Web Forms.

I tried to integrate the WEB API 2.0 through NUGET.

It was unsuccessful . It was not showing any meaningful message.

I created any  web form with .NET 4.0 and tried to add WEB API 2.0 through NUGET.

It gave meaningful message. To add WEB API 2.0 , you need to use .NET 4.5.

I upgraded all projects to 4.5.

AJAXMETHODS stopped working .

I goggled and found the following solution

http://forums.asp.net/t/1861258.aspx?calling+Ajax+AjaxMethod+not+working
https://prakashrthd.wordpress.com/2014/02/04/calling-ajax-ajaxmethod-not-working/
 

No comments:

A period of stability

Rocky says In both those cases there was a 5-6 year window when the platforms were slow-changing, the dev tools were mature, and disru...